Install/Upgrade Error: Input string was not in a correct format


I had to apply GP 2016 YE2016 (16.00.0579) on my GP2016 R2 environment. I had several customisations deployed and wanted to remove them before applying the YE2016 patch.

Obviously, I’d upgrade my customisations to 16.00.0579 once my GP is upgraded. However, while trying to apply YE2016, following error message popped up out of nowhere.

Screen Shot 2017-04-27 at 03.32.02 pm

I had never seen this error before. It was certainly a bit baffling. Not even Google is good compared to our GP community forum to find answers. I came up with this: Installation error ‘Input string was not in a correct format’

Apparently, it was my DYNAMICS.SET that was causing this issue. I removed my customisation dictionaries from GP folder, removed all necessary entries from my SET file. However, I totally forgot to reduce the number of dictionaries at the top of my SET file. Silly me!

Once I corrected my SET file, I was able to apply the YE2016 patch. All was well.

One thing I would like to emphasise here: Those who post questions on our GP forum, please mark the response as “answer” without fail. You would help others who search for an answer. You’d also give due credit to the person who shared his/her knowledge.

Vaidy

SmartConnect 2010 Hotfix – Crucial


There is a SmartConnect 2010 Hotfix available now, which is crucial for 64 Bit Installations specifically.

More details here: SmartConnect 2010 Hotfix.

VAIDY